Strict Standards: Non-static method phpbb_captcha_factory::get_instance() should not be called statically in /nfs/c05/h01/mnt/83021/domains/edawn-mod.org/html/forum/posting.php on line 185

Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method phpbb_captcha_qa::get_instance() should not be called statically in /nfs/c05/h01/mnt/83021/domains/edawn-mod.org/html/forum/includes/captcha/captcha_factory.php on line 38
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4586: Cannot modify header information - headers already sent by (output started at /posting.php:185)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4588: Cannot modify header information - headers already sent by (output started at /posting.php:185)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4589: Cannot modify header information - headers already sent by (output started at /posting.php:185)
[phpBB Debug] PHP Warning: in file /includes/functions.php on line 4590: Cannot modify header information - headers already sent by (output started at /posting.php:185)
excessive dawn • Post a reply

Quake3 1.32e

Post a reply


This question is a means of preventing automated form submissions by spambots.
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: Quake3 1.32e

Re: Quake3 1.32e

Post by ZerTerO » 2017-05-17 07:25:11

If i start a map with missing textures, then i get with quake3.exe some error messages in the console. I don't get this messages with quake3e.exe.

Re: Quake3 1.32e

Post by Cyrax » 2017-05-11 19:14:51

This is an attempt to fix 32 dead keys on RU/UA keyboard layouts, for example. It is possible to fix your problems by changing just one directMap() function but I will need your feeback to test experimental binaries

Re: Quake3 1.32e

Post by ZerTerO » 2017-05-11 17:49:40

The most important examples :

/ in GER is & in ENG
_ in GER is ? in ENG
/ in ENG is - in GER
_ in ENG is ? in ENG

The german layout is QWERTZ. The Problem is: If I want to enter this here: "/in_forceLayout 0" then I have to press these buttons "-in?forceLazout 0". And that is very confusing. With the latest version of Quake3 1.32e has all worked perfectly. Had also no problem with English systems too. I do not understand why this is now standard. This will confuse many people without EN layout.

Re: Quake3 1.32e

Post by Cyrax » 2017-05-11 16:44:23

ZerTerO wrote:09-May-2017:
Please, please disable this by default. I come from germany and took a long time to switch this option off in the console. Why does it have to be activated by default? Why is this cvar needed? Not many people in the world have a keyboard with EN/US keyboard layout... :(
What layout you have and what keys is not working properly for you? I can fix that AZERTY stuff (temporary disabled that) but I need some feedback.

I will explain why I enabled it by default: it fixes bind inconsistency on windows i.e. when you type 'bind a +moveleft' on azerty layout - when later you press 'a' - it will execute 'q' key bind because bind keys actually (if on-sceen keybard simulation is correct) connected to physical scancdodes and 'a' azerty key is 'q' by its scancode.
With new behavior you always have constant physical bind layout so it will work with any keyboard settings, it also fixes 'dead keys' which comes with non-US/EN layouts

Re: Quake3 1.32e

Post by ZerTerO » 2017-05-11 11:14:18

09-May-2017:

[...]
* Add \in_forceLayout - to use EN/US keyboard layout not depending from current language settings, enabled by default
[...]

Please, please disable this by default. I come from germany and took a long time to switch this option off in the console. Why does it have to be activated by default? Why is this cvar needed? Not many people in the world have a keyboard with EN/US keyboard layout... :(

Re: Quake3 1.32e

Post by Cyrax » 2017-04-30 09:53:21

ZerTerO wrote:Great Work! I love it. What are the plans for the future?
Thank you. Turn back multiview, use glsl for gamma and high-quality bloom, some QVM improvements
casual player wrote:in vanilla q3 and osp, color1/color2 doesnt seem to have any effect and rail color is always white.
Now fixed

Re: Quake3 1.32e

Post by casual player » 2017-04-28 23:58:45

in vanilla q3 and osp, color1/color2 doesnt seem to have any effect and rail color is always white.

Re: Quake3 1.32e

Post by ZerTerO » 2017-04-26 12:24:53

Great Work! I love it. What are the plans for the future?

Re: Quake3 1.32e

Post by Cyrax » 2017-04-09 11:45:54

T^kon wrote:Win32 build hard crashes if there is a q3config.cfg in baseq3 folder that was build by an IOQ3-client.
Thank you for report, will be fixed 8-)

Re: Quake3 1.32e

Post by T^kon » 2017-04-02 19:57:02

Not that spectacular, but a Win32 build hard crashes if there is a q3config.cfg in baseq3 folder that was build by an IOQ3-client.

Example -> http://www.dm17.com/~sp/q3config.cfg

Top